Back to overview
Degraded

Kubernetes node install broken due to broken curl security patch on Ubuntu

Jul 19 at 05:53pm CEST
Affected services
Kubernetes - aws - eu-west-1

Resolved
Jul 19 at 07:03pm CEST

We have released new patches which avoid the issue with the backported patch for curl on Ubuntu 22.0.4 machines.

Released new patches

  • v1.27.3-u-ame.6
  • v1.26.6-u-ame.5
  • v1.25.11-u-ame.5
  • v1.24.15-u-ame.5

Created
Jul 19 at 05:53pm CEST

Currently it is not possible to join new nodes due to an issue related to curl and githubusercontent.com which is used during the node bootstrap phase.

This has no impact on running nodes.

We are working to resolve the issue.

See also:
https://bugs.launchpad.net/ubuntu/+source/curl/+bug/2028170
https://github.com/curl/curl/issues/11475